Sabtu, 18 Februari 2017

COFIGURASI BASH

COFIGURASI BASH


What Is a Bash ?
Gambar terkait  Bash adalah Unix shell dan perintah bahasa yang ditulis oleh Brian Fox untuk Proyek GNU sebagai perangkat lunak bebas pengganti shell Bourne . Pertama kali dirilis pada tahun 1989, telah didistribusikan secara luas sebagai shell default untuk Linux distribusi dan Apple MacOS (sebelumnya OS X).
  
  Bash adalah prosesor perintah yang biasanya berjalan di jendela teks, di mana pengguna jenis perintah yang menyebabkan tindakan. Bash juga dapat membaca perintah dari file, yang disebut skrip . Seperti semua kerang Unix, mendukung nama file globbing (pencocokan wildcard), pipa , di sini dokumen , substitusi perintah , variabel dan struktur kontrol untuk kondisi-pengujian dan iterasi . The kata kunci , sintaks dan fitur dasar lain dari bahasa semua disalin dari sh .

 #Latar Belakang
Mengetahui lebih dalam lagi tentang Bash

#Maksud Dan Tujuan
Mempraktekkan materi tentang installasi Bash

#Alat Dan Bahan 
- Modul Bash
- Internet

#Tahap Penyelesaian 
Langkah-langkah untuk konfigurasi bash sebagai berikut ini :

1.Pertama kalian ketikkan perintah nano /etc/bash.bashrc

2.Setelah muncul seperti dibawah ini, kalian edit #| enable bash completion in interactive shells meNjadi    | enable bash completion in interactive shells kemudian keluar dengan perintah CTRL+X tekan Y lalu Enter

~~~~~~~~~~~~~~~~~~~~~SELAMAT MENCOBA~~~~~~~~~~~~~~~~~~~~~



Jumat, 17 Februari 2017

MENGINSTALL ZOIPER

MENGINSTALL ZOIPER 


What is a Zoiper?

Hasil gambar untuk zoiper - wikipedia  Sebuah softphone adalah software program yang untuk membuat panggilan telepon melalui Internet menggunakan komputer tujuan umum, daripada menggunakan hardware khusus. softphone juga dapat diinstal pada sebuah peralatan seperti workstation, komputer portabel, tablet atau bahkan ponsel dan memungkinkan pengguna untuk menempatkan dan menerima panggilan tanpa memerlukan pesawat telepon yang sebenarnya. Sering softphone dirancang untuk berperilaku seperti tradisional telepon , kadang-kadang muncul sebagai gambar dari telepon, dengan panel display dan tombol dengan mana pengguna dapat berinteraksi. Sebuah softphone biasanya digunakan dengan headset terhubung ke kartu suara dari PC, atau dengan telepon USB .



#latar belakang
Mempelajari dan mempraktekkan modul tentang VoIP server yang menggunakan Zoip

#maksud dan tujuan
Menginstall VoIP server untuk membuat panggilan telepon menggunakan Zoiper

#alat dan bahan
- Laptop/Pc
- Referensi
- Internet

#tahap penyelesaian

Sebelumnya kalian sudah menginstall asterisk nah...... sekarang saatnya untuk menginstall Zoiper . Jika belum punya file Zoiper-nya silahkan klik disini. langkah-langkah-nya sebagai berikut ini :

 1.  silahkan anda buka terminal linux-nya , kemudian cari file Zoiper-nya lalu extra dengan perintah tar xvf Zoiper_3.3_linux_Free_32Bit_64Bit.tar.gz lalu tekan enter . silahkan pilih file yang akan di install. 


2. Kemudian install file yang sudah dipilih dengan perintah ./ Zoiper_3.3_Linux_Free_32Bit.run lalu tekan enter.


3. Maka akan muncul tampilan seperti ini , kemudian klik forward


4. Kemudian pilih I accept the agreement kemudian klik forward.


5. Pastikan Add Desktop shortcut sudah tercentang, klik forward.


6. Pastikan Juga File Zoiper-nya ada di /usr/share/Zoiper , klik forward.


7.  Kemudian akan muncul pesan seperti di bawah ini , klik forward


8. Insrtllasi sudah selesai , klik finish.


9. Maka akan muncul tampilan sperti ini , klik yes.






~~~~~~~~~~~~~~~SELAMAT MENCOBA~~~~~~~~~~~~~~~


Kamis, 16 Februari 2017

MENGINSTALL VOIP

MENGINSTALL VOIP 




What Is a VOIP?
Hasil gambar untuk voip wiki  Voice over Internet Protocol (Voice over IP, VoIP dan IP telephony) adalah metodologi dan kelompok teknologi untuk pengiriman komunikasi suara dan multimedia sesi selama Internet Protocol (IP) jaringan, seperti Internet . Istilah internet telephony, broadband telephony, dan layanan telepon broadband secara khusus mengacu pada penyediaan layanan komunikasi (suara, fax , SMS , pesan suara) melalui Internet publik, bukan melalui public switched telephone network (PSTN). Untuk mengetahui lebih tentang VoIP silahkan anda klik disini.

#latar belakang
Mempelajari dan mempraktekkan modul tentang VoIP server yang menggunakan asterisk

#maksud dan tujuan
Menginstall VoIP server untuk membuat panggilan telepon menggunakan asterisk

#alat dan bahan
- Laptop/Pc
- Modul VoIP server
- Internet

#tahap penyelesaian 
  Untuk membuat panggilan telepon ada 2 yang harus dinstall yaitu asterisk dan Aplikasi Zoiper .Sekarang kita install terlebih dahulu asterisk-nya , berikut ini langkah-langkah-nya :

1.  Silahkan anda masuk ke terminal linux , kemudian ketikkan apt-get install asterisk . lalu tekan enter.


2. Lalu tekan Y dan enter


3. Jika muncul pesan seperti berikut ini,  silahkan anda ketikkan y lalu tekan enter.


4. Setelah itu konfigurasi sip-nya dengan perintah nano /etc/asterisk/sip.conf . lalu tekan enter.


5. Silahkan anda tambahkan pada bagian paling bawah , berikut ini script-nya :

[general]
port = 5060
bindaddr = 0.0.0.0
context = others

[1921681374]
type=friend
context=myphones
secret=1234
host=dynamic

[1921681375]
type=friend
context=myphones
secret=1234
host=dynamic

kalau sudah selesai keluar dengan perintah CTRL +X  lalu Y kemudian enter.


6. Setelah itu konfigurasi extentions-nya dengan perintah nano /etc/asterisk/extentions.conf . lalu tekan enter.


7. Pada baagian bawah , silahkan anda tambahkan :

[others]
[myphones]
exten => 1921681374,1,Dial(SIP/1921681374)
exten => 1921681375,1,Dial(SIP/1921681375)

Kalau sudah , keluar dengan perintah CTRL + X lalu Y kemudoan tekan enter.


8. Kemudian restart asterisk-nya dengan perintah /etc/init.d/asterisk restart, lalu enter.









~~~~~~~~~~~SELAMAT MENCOBA~~~~~~~~~~~

























Selasa, 14 Februari 2017

MENGATASI MASALAH Malformed line in the source list /etc/apt/sources.list (URL) SAAT UPDATE

MENGATASI MASALAH Malformed line in the source list /etc/apt/sources.list (URL) SAAT UPDATE


Hasil gambar untuk problem in updateHi....... bertemu lagi di blog saya.saya mau nanya apakah kalian pengguna linux/saudara-saudara-nya linux pernah mengalami masalah  Malformed line in the source list /etc/apt/sources.list (URL) . Sudah cari solusinya?apakah kalian menemukan solusinya?. nah.......... dari pada kalian bingung cari solusinya , saya akan bagikan bagaimana cara memperbaiki masalah tersebut.



#Latar belakang 
Terjadi masalah saat meng-update file yang ada di server

#Maksud dan tujuan
Memperbaiki  masalah  saat update di server

#Tahap penyelesaian
Tanpa basa-basi lagi , langsung saja ke penyelesaiannya . Langkah-langkah sebagai berikut :

1. Pastikan dulu masalah-nya , masuk ke terminal lalu ketikkan apt-get update. lalu tekan enter.


2. Jika sudah silahkan anda ketikkan head -n 6 /etc/apt/sources.list | tail -n 1 , kemudian tekan enter .maka akan muncul  dibawah-nya berupa repository yang bermasalah.




3. Lalu silahkan anda masuk ke file repository dengan perintah nano /etc/apt/sources.list. kemudian tekan enter.



4. Lalu cari repository yang bermasalah tadi , kemudian silahkan anda beri tanda # di depan file repository yang bermasalah.kalau sudah silahkan anda save lalu keluar dengan menekan CTRL+X kemudian Y lalul enter.























5. Silahkan anda update lagi .




~~~~~~~~~~~~~~~~~SELAMAT MENCOBA~~~~~~~~~~~~~~~~~

Senin, 13 Februari 2017

CONFIGURASI HTTP

CONFIGURASI HTTP




Hasil gambar untuk HTTP



MAKSUD DAN TUJUAN
  • Untuk Membuat jaringan aman atau Secure network , maka kita mangaktifkan SSL . dan juga membuka port 443
 
LATAR BELAKANG 
  • Karena protokol HTTP belum sepenuhnya secure maka di perlukan protokol HTTPS dan membuka port 443 (HTTPS)
ALAT DAN BAHAN
  • Server (Webserver apache2)
  • Laptop / PC
  • Internet
 


TAHAP PELAKSANAAN    
1. Masuk ke server menggunakan ssh, setelah itu generate certificate ssl nya menggunakan perintah,

# openssl req -new -x509 -days 365 -nodes -out /etc/apache2/apache2.pem -keyout /etc/apache2/apache2.pem Tunggu sampai perosesnya selesai nya selesai. Dan masukan keterangan sebagai berikut:

[AU] ID
[Some-State] East Java
[city] Klaten
[internet widgits pty ltd] BLC "isikan nama organisasi atau nama instansi"
[sectoin]                                  "ini seperti organisasi lain yang kalian ikuti, jadi bisa tidak diisi"
[your name] forpis.gov (nama domain)
[email] admin@forpis.gov




2. Setelah di generate certificate ssl nya, selanjutnya enable ssl menggunakan perintah.

# a2enmod ssl 


3. Restart Apache2 dengan perintah # service apache2 restart atau # /etc/init.d/apache2 restart
4. Setelah di enable mode ssl nya . Lanjut ke langkah berikutnya yaitu mengecek apakah port 443 udah listen pada konfigurasi ports.

# nano /etc/apache2/ports.conf



Pastikan Ada listen port 443 seperti gambar.


5. Next, edit file konfigurasi "# /etc/apache2/sites-available/000-default.conf" , dengan masukan perintah:

#nano /etc/apache2/sites-available/000-default.conf



dan tambahkan:


ServerName forpis.gov   (domain anda) 

ServerAlias www.forpis.gov (domain anda)
 

SSLEngine on
SSLCertificateFile /etc/apache2/apache2.pem


jika sudah lalu CTRL+X lalu y dan enter.
 

 6. Lanjut Restart service dari apache2 menggunakan perintah

# /etc/init.d/apache2 restart




 7. Kemudian kita akses melalui web browser dengan mengetikan:
 
 https://(ip server) misal https://192.168.40.2

 8. Nah, jika Connection is not secure jangan panik dan tetap tenang, KLik Advance kemudian Add Exception. 
 

 9. Dan kemudian akan muncul tab seperti ini klik Confirm Security Exception saja.
 10. Well Yeaaahhhh, akhirnya jadi sudah HTTPS sudah berhasil atau aktif.

Sabtu, 11 Februari 2017

DEFINISI HTTP

Hypertext Transfer Protocol (HTTP)


#PENGERTIAN
Hasil gambar untuk HTTP  Hypertext Transfer Protocol (HTTP) adalah sebuah protokol aplikasi untuk didistribusikan, kolaboratif, sistem informasi hypermedia. [1] HTTP adalah dasar komunikasi data untuk World Wide Web.

  Hypertext terstruktur teks yang menggunakan link logis (hyperlink) antara node yang berisi teks. HTTP adalah protokol untuk bertukar atau hypertext transfer.

  Pengembangan HTTP diprakarsai oleh Tim Berners-Lee di CERN pada tahun 1989. pengembangan Standar HTTP dikoordinasi oleh Internet Engineering Task Force (IETF) dan World Wide Web Consortium (W3C), yang berpuncak pada publikasi serangkaian Permintaan komentar (RFC). Definisi pertama dari  / 1.1, versi HTTP yang umum digunakan, terjadi di RFC 2068 pada tahun 1997, meskipun ini usang oleh RFC 2616 pada tahun 1999 dan kemudian lagi oleh RFC 7230 dan keluarga pada tahun 2014.

  Sebuah versi yang lebih baru, penerus HTTP / 2, adalah standar pada tahun 2015, dan kini didukung oleh server web utama.


  Fungsi HTTP sebagai permintaan-respon protokol di model komputasi client-server . Sebuah browser web , misalnya, mungkin klien dan aplikasi yang berjalan pada komputer tuan sebuah situs mungkin server. Klien mengajukan HTTP pesan permintaan ke server. Server, yang menyediakan sumber daya seperti file HTML dan konten lainnya, atau melakukan fungsi lainnya atas nama klien, mengembalikan pesan respon ke klien. Tanggapan berisi informasi status penyelesaian tentang permintaan dan mungkin juga mengandung konten yang diminta dalam tubuh pesannya.
  Sebuah web browser adalah contoh dari agen pengguna (UA). Jenis lain dari agen pengguna termasuk perangkat lunak pengindeksan digunakan oleh penyedia layanan pencarian ( web crawler ), browser suara , aplikasi mobile , dan lain software yang mengakses, mengkonsumsi, atau menampilkan konten web.
  HTTP dirancang untuk memungkinkan elemen jaringan menengah untuk meningkatkan atau mengaktifkan komunikasi antara klien dan server. Situs-lalu lintas tinggi seringkali mendapatkan keuntungan dari web cache server yang memberikan konten atas nama server hulu untuk meningkatkan waktu respon. Web browser sebelumnya cache diakses sumber web dan menggunakan kembali mereka bila mungkin untuk mengurangi lalu lintas jaringan. HTTP proxy server di jaringan pribadi batas dapat memfasilitasi komunikasi untuk klien tanpa alamat global routable, dengan menyampaikan pesan dengan server eksternal.
HTTP adalah sebuah lapisan aplikasi protokol yang dirancang dalam rangka protokol internet . Definisi mengandaikan suatu yang mendasari dan terpercaya lapisan transport protokol, dan Transmission Control Protocol (TCP) yang biasa digunakan. Namun HTTP dapat disesuaikan dengan menggunakan protokol tidak dapat diandalkan seperti User Datagram Protocol (UDP), misalnya dalam HTTPU dan Simple Service Discovery Protocol (SSDP).
Sumber HTTP diidentifikasi dan terletak pada jaringan dengan Uniform Resource Locators (URL), menggunakan Uniform Resource Identifier skema (URI) http dan https. URI dan hyperlink di HTML dokumen membentuk saling terkait hypertext dokumen.
HTTP / 1.1 merupakan revisi dari HTTP asli (HTTP / 1.0). Dalam HTTP / 1.0 yang terpisah koneksi ke server yang sama dibuat untuk setiap permintaan sumber daya. HTTP / 1.1 bisa menggunakan kembali sambungan beberapa kali untuk men-download gambar, skrip , stylesheet , dll setelah halaman telah disampaikan. Oleh karena itu HTTP / 1.1 komunikasi mengalami kurang latency sebagai pembentukan koneksi TCP menyediakan overhead yang cukup.

#SEJARAH

Tim Berners-Lee
Istilah hypertext ini diciptakan oleh Ted Nelson pada tahun 1965 di Xanadu Project , yang pada gilirannya terinspirasi oleh Vannevar Bush visi 's (1930) dari pengambilan informasi berbasis microfilm dan manajemen " memex sistem" yang dijelaskan dalam esainya As We May Think (1945). Tim Berners-Lee dan timnya di CERN dikreditkan dengan inventing HTTP asli bersama dengan HTML dan teknologi yang terkait untuk web server dan web browser berbasis teks. Berners-Lee pertama kali mengajukan "WorldWideWeb" proyek pada tahun 1989 - sekarang dikenal sebagai World Wide Web . Versi pertama dari protokol hanya memiliki satu metode, yaitu GET, yang akan meminta halaman dari server.  Tanggapan dari server selalu halaman HTML. 
Versi didokumentasikan pertama dari HTTP adalah HTTP v0.9 (1991). Dave Raggett memimpin Kelompok Kerja HTTP (HTTP WG) pada tahun 1995 dan ingin memperluas protokol dengan operasi diperpanjang, negosiasi diperpanjang, kaya meta-informasi, diikat dengan protokol keamanan yang menjadi lebih efisien dengan menambahkan metode tambahan dan field header .  RFC 1945 secara resmi diperkenalkan dan diakui V1.0 HTTP pada tahun 1996.
HTTP WG berencana untuk mempublikasikan standar baru pada Desember 1995 dan dukungan untuk pra-standar HTTP / 1.1 berdasarkan kemudian mengembangkan RFC 2068 (yang disebut HTTP-NG) dengan cepat diadopsi oleh pengembang browser besar di awal tahun 1996. Dengan Maret 1996, pra-standar HTTP / 1.1 didukung di Arena ,  Netscape 2.0 , Netscape Navigator Emas 2,01,  Mosaic 2.7 , [ rujukan? ] Lynx 2.5 , [ rujukan? ] dan di Internet Explorer 2.0 . [ Rujukan? ] Adopsi pengguna akhir dari browser baru itu cepat. Pada bulan Maret 1996, salah satu perusahaan web hosting melaporkan bahwa lebih dari 40% dari browser yang digunakan di Internet adalah HTTP 1.1 compliant. [ Rujukan? ] Itu web hosting perusahaan yang sama melaporkan bahwa pada bulan Juni tahun 1996, 65% dari semua browser mengakses server mereka HTTP / 1.1 compliant. HTTP / 1.1 standar seperti yang didefinisikan dalam RFC 2068 secara resmi dirilis pada bulan Januari 1997. Perbaikan dan pembaruan untuk HTTP / 1.1 standar yang dirilis di bawah RFC 2616 pada bulan Juni 1999.
Pada tahun 2007, Kelompok Kerja HTTPbis dibentuk, sebagian, untuk merevisi dan mengklarifikasi HTTP / 1.1 spesifikasi. Pada bulan Juni 2014, WG merilis update enam-bagian spesifikasi obsoleting RFC 2616 :
  • RFC 7230 , HTTP / 1.1: Pesan Syntax dan Routing
  • RFC 7231 , HTTP / 1.1: Semantik dan Konten
  • RFC 7232 , HTTP / 1.1: Permintaan Bersyarat
  • RFC 7233 , HTTP / 1.1: Rentang Permintaan
  • RFC 7234 , HTTP / 1.1: Caching
  • RFC 7235 , HTTP / 1.1: Authentication
HTTP / 2 diterbitkan sebagai RFC 7540 Mei 2015.


#SESI HTTP

Sesi HTTP adalah urutan jaringan transaksi permintaan-respon. Klien HTTP memulai permintaan dengan membentuk Transmission Control Protocol (TCP) koneksi ke tertentu pelabuhan pada server (biasanya port 80, kadang-kadang port 8080, lihat Daftar TCP dan nomor port UDP ). Server HTTP mendengarkan pada port yang menunggu untuk klien pesan permintaan. Setelah menerima permintaan, server akan mengirimkan kembali baris status, seperti "HTTP / 1.1 200 OK", dan pesan tersendiri. Tubuh pesan ini biasanya adalah sumber daya yang diminta, meskipun pesan kesalahan atau informasi lainnya mungkin juga dikembalikan.




#HTTP Authentication

HTTP menyediakan beberapa skema otentikasi seperti otentikasi akses Dasar dan Digest otentikasi akses yang beroperasi melalui mekanisme tantangan-respon dimana mengidentifikasi server dan isu-isu tantangan sebelum melayani konten yang diminta.
HTTP menyediakan kerangka umum untuk kontrol akses dan otentikasi, melalui set extensible skema otentikasi tantangan-respon, yang dapat digunakan oleh server untuk menantang permintaan klien dan dengan klien untuk memberikan informasi otentikasi. 

#Otentikasi Realms

HTTP Authentication spesifikasi juga menyediakan sewenang-wenang, pelaksanaan konstruksi khusus untuk lebih membagi sumber daya umum untuk akar diberikan URI. Nilai ranah string, jika ada, dikombinasikan dengan URI akar kanonik untuk membentuk komponen ruang perlindungan tantangan. Ini berlaku memungkinkan server untuk menentukan lingkup otentikasi terpisah di bawah satu akar URI 

#Metode permintaan


HTTP mendefinisikan metode (kadang-kadang disebut sebagai kata kerja) untuk menunjukkan tindakan yang diinginkan yang akan dilakukan pada sumber daya diidentifikasi. Apa sumber daya ini mewakili, apakah data yang sudah ada atau data yang dihasilkan secara dinamis, tergantung pada pelaksanaan server. Seringkali, sumber daya sesuai dengan file atau output dari sebuah eksekusi yang berada di server. HTTP / 1.0 spesifikasi  mendefinisikan GET, POST dan KEPALA metode dan HTTP / 1.1 spesifikasi menambahkan 5 metode baru: PILIHAN, PUT, DELETE, TRACE dan CONNECT. Dengan yang ditentukan dalam dokumen-dokumen semantik mereka sudah dikenal dan dapat bergantung pada. Setiap klien dapat menggunakan metode apapun dan server dapat dikonfigurasi untuk mendukung setiap kombinasi metode. Jika metode ini tidak diketahui untuk perantara itu akan diperlakukan sebagai tidak aman dan non-idempoten metode. Tidak ada batasan untuk jumlah metode yang dapat didefinisikan dan ini memungkinkan untuk metode masa depan akan ditentukan tanpa melanggar infrastruktur yang ada. Misalnya, WebDAV didefinisikan 7 metode baru dan RFC 5789 ditentukan PATCH metode.